The StopWatch App Professional runs on following Garmin wearables

  • Approach® S60
  • D2® Charlie 
  • D2 Bravo, D2 Bravo Titanium
  • Descent™ MK1
  • ForeAthlete® 230J, 235J, 630J, 735XTJ and 920XTJ
  • Forerunner® 230, 235, 630, 735XT, 920XT and 935XT
  • Epix
  • Fēnix® 3, Fēnix® 3 HR, Fēnix® Chronos
  • Fēnix® 5, Fēnix® 5SFēnix® 5X, Fēnix® 5 Quatix
  • Vivoactive™, Vivoactive™ HR, Vivoactive® 3

Requirements (mandatory):

  • Please install the latest firmware on your wearable. Here the information about the minimum required Connect IQ version depending on your wearable type:
    >= 1.2.1: Epix
    >= 1.3.0: Vivoactive® , Forerunner® 230, 235, 630 and 920XT, ForeAthlete® 230J, 235J, 630J and 920XTJ, 
    >= 1.4.1: Fēnix® 3, Fēnix® 3 HR, D2 Bravo, D2 Bravo Titanium
    >= 2.2.0: 
    Forerunner® 735XT and ForeAthlete® 735J, Vivoactive® HR
    >= 2.2.0: Fēnix® 5Fēnix® 5SFēnix® 5X , Fēnix® 5 Quatix, Forerunner® 935XT, Fēnix® Chronos
    >=2.3.0: 
    D2® Charlie, Vivoactive® 3, Approach® S60, Descent™ MK1
  • Please install the latest Garmin Connect App if you use the mobile phone for installation and configuration
  • Please install the latest Garmin Express Version if you use the PC/MAC for installation and configuration